全國最多中醫師線上諮詢網站-台灣中醫網
發文 回覆 瀏覽次數:2949
推到 Plurk!
推到 Facebook!

delphi 6 SPCOMM 資料傳輸問題

答題得分者是:mephise
pai_stanley
一般會員


發表:1
回覆:0
積分:0
註冊:2008-03-14

發送簡訊給我
#1 引用回覆 回覆 發表時間:2008-03-24 00:06:45 IP:202.86.xxx.xxx 訂閱
各位先進大家好:
使用RS232 SPCOMM 傳送資料的問題
當使用 SPCOMM 在 delphi 3 時 接收 傳出 資料都很正常
但SPCOMM 在使用 delphi 6 時 接收正常 但傳出資料 卻都是亂碼 (設定也都沒問題 9600,N,8,1)
(測試是用 一端pc使用編寫的程式 另一端pc是使用附屬應用程式裡的 超級終端機)
請問有解決方式嗎? 謝謝各位先進!
------
小白
max5020
資深會員


發表:26
回覆:275
積分:320
註冊:2003-06-04

發送簡訊給我
#2 引用回覆 回覆 發表時間:2008-04-16 11:30:19 IP:59.120.xxx.xxx 訂閱
會不會是以前在用Dephi-3時,
設備比較舊, 速度也比較慢,
更新設備後,
速度變快了,
某些TIMER沒有設定好!!
猜看看囉, 好像有點難猜!!!!!!
mcho
初階會員


發表:57
回覆:106
積分:42
註冊:2002-11-11

發送簡訊給我
#3 引用回覆 回覆 發表時間:2008-04-19 10:14:09 IP:203.79.xxx.xxx 訂閱
pai_stanley:你好!
我對SPCOMM這個元件不了解
請問有沒有裝在delphi 5上試過因為我沒有用過
不知如何寫 可否port出接收 傳出的範例出來參考
我也想測試這個元件! 對不起沒幫上忙返而找你的麻煩!

===================引 用 pai_stanley 文 章===================
各位先進大家好:
使用RS232 SPCOMM 傳送資料的問題
當使用 SPCOMM 在 delphi 3 時 接收 傳出 資料都很正常
但SPCOMM 在使用 delphi 6 時 接收正常 但傳出資料 卻都是亂碼 (設定也都沒問題 9600,N,8,1)
(測試是用 一端pc使用編寫的程式 另一端pc是使用附屬應用程式裡的 超級終端機)
請問有解決方式嗎? 謝謝各位先進!
------
何明昌
mephise
高階會員


發表:4
回覆:149
積分:205
註冊:2004-02-09

發送簡訊給我
#4 引用回覆 回覆 發表時間:2008-06-07 21:14:05 IP:220.137.xxx.xxx 訂閱
從Delphi3 一直用到 Delphi7 都沒遇過上述問題
我猜有以下可能
1. 元件安裝時不是使用 pas 而是用 dcu 檔, 請用pas檔, 由Delphi6重新Compile一次
2. 有考慮到 Unicode 的問題嗎
------
Mephise Chen
前興德工程師
系統時間:2017-12-13 22:44:19
聯絡我們 | Delphi K.Top討論版
本站聲明
1. 本論壇為無營利行為之開放平台,所有文章都是由網友自行張貼,如牽涉到法律糾紛一切與本站無關。
2. 假如網友發表之內容涉及侵權,而損及您的利益,請立即通知版主刪除。
3. 請勿批評中華民國元首及政府或批評各政黨,是藍是綠本站無權干涉,但這裡不是政治性論壇!