DELPHI 7 WebService 製作簡介

前提
首先必須是 DELPHI 7,試過 DELPHI 6 UP2 無法使用(不知道別人可不可以使用)
WebService 很類似 3 Tier ,後端資料庫可自行設定
最重要的找一個能放程式的地方作測試

若有錯誤,敬請批評指教
歡迎修改新增
Ver : 1.0 　Free

作者: Joey Chen


DELPHI 7 WebService 製作簡介

Server 端程式

首先
File/New/Other..

選擇 SOAP Server Application 按 OK,會出現

選擇 CGI Stand-alone executable,按 OK

(我不知道這個對話視窗的主要用意) 按 NO 會出現

選取 WSDLHTMLPublish1

在 TargetNamespace 輸入你的主機位址 例: http://tempuri.org/ (不改似乎也無所謂)

再來是資料庫連接
File/New/Other..

選擇 SOAP Server Data Module 按 OK,會出現

輸入資料模組名稱,按 OK

資料模組的使用方式,與一般 3 Tier 資料模組相同

將產生的執行檔放到 Web 伺服器的目錄上

如此便完成 Server 端程式


Web Server 部份

Client 端程式

首先
File/New/Application 即是一般應用程式

放入 SoapConnection1,ClientDataSet1,DataSource1

在 SoapConnection1 的 URL 輸入你的網路位址跟執行檔名稱在接上 "/Soap/

執行檔名稱就是 Server 程式的名稱

例 : http://你的網路位址/執行檔名稱/soap/

然後 Connected 設為 True

在 ClientDataSet1 的 RemoteServer 選取 SoapConnection1

在 ProviderName 選取 DataSetProvider1 (就是 Server 程式的 DataSetProvider1 名稱)

然後 DBGrid 跟 DataSource 設定好

ClientDataSet1 的 Active 屬性設為 True, 便可看見資料跑出來

Client 端其他都與一般一樣


Web Server 部份

Web 伺服器設定
在使用權限 改成指令碼與執行檔