線上訂房服務-台灣趴趴狗聯合訂房中心
發文 回覆 瀏覽次數:2088
推到 Plurk!
推到 Facebook!

ADOTable:missing connection

答題得分者是:老大仔
ann0509
一般會員


發表:19
回覆:42
積分:12
註冊:2010-08-09

發送簡訊給我
#1 引用回覆 回覆 發表時間:2010-08-18 10:18:00 IP:60.248.xxx.xxx 訂閱
請問各位大大

當我使用ADOTable 這個元件的時候
他就會依職出現 ADOTable:missing connection
這個錯誤
不知道應該怎麼辦啊~~
可以幫幫我嗎
老大仔
尊榮會員


發表:77
回覆:835
積分:1082
註冊:2006-07-06

發送簡訊給我
#2 引用回覆 回覆 發表時間:2010-08-18 10:39:00 IP:59.120.xxx.xxx 未訂閱
1. ConnectionString設了嗎??
2. 請用"missing connection" 爬文

===================引 用 ann0509 文 章===================
請問各位大大

當我使用ADOTable 這個元件的時候
他就會依職出現 ADOTable:missing connection
這個錯誤
不知道應該怎麼辦啊~~
可以幫幫我嗎
ann0509
一般會員


發表:19
回覆:42
積分:12
註冊:2010-08-09

發送簡訊給我
#3 引用回覆 回覆 發表時間:2010-08-18 11:02:22 IP:60.248.xxx.xxx 訂閱
ConnectionString 設了之後
卻出現form 子句中的語法錯誤了
應該怎麼改呢

===================引 用 老大仔 文 章===================
1. ConnectionString設了嗎??
2. 請用"missing connection" 爬文

===================引 用 ann0509 文 章===================
請問各位大大

當我使用ADOTable 這個元件的時候
他就會依職出現 ADOTable:missing connection
這個錯誤
不知道應該怎麼辦啊~~
可以幫幫我嗎
編輯記錄
ann0509 重新編輯於 2010-08-18 11:10:29, 註解 無‧
老大仔
尊榮會員


發表:77
回覆:835
積分:1082
註冊:2006-07-06

發送簡訊給我
#4 引用回覆 回覆 發表時間:2010-08-18 12:02:07 IP:59.120.xxx.xxx 未訂閱
既然是語法錯誤了
那就應當先檢查您的SQL語法是否正確、標點符號是否有問題

請先將語法貼到SQL Query Analyzer 執行
哪裡錯了它會跟您提示
要不然就把sql貼上來
讓大家幫您看看

===================引 用 ann0509 文 章===================
ConnectionString 設了之後
卻出現form 子句中的語法錯誤了
應該怎麼改呢


ann0509
一般會員


發表:19
回覆:42
積分:12
註冊:2010-08-09

發送簡訊給我
#5 引用回覆 回覆 發表時間:2010-08-18 14:07:44 IP:60.248.xxx.xxx 訂閱
ADOTable2.ConnectionString:= 'Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\S_Table\'+ S +'.mdb';
ADOTable2.TableName := 'C:\S_Table\' S '.MDB\' S;

s 是我建立的資料庫名子跟資料庫資料表名子
我用輸入的方式 建立的
我寫第一行的時候不會有錯誤
到第二行的時候就會出現語法錯誤
編輯記錄
ann0509 重新編輯於 2010-08-18 14:08:51, 註解 無‧
老大仔
尊榮會員


發表:77
回覆:835
積分:1082
註冊:2006-07-06

發送簡訊給我
#6 引用回覆 回覆 發表時間:2010-08-18 14:10:57 IP:59.120.xxx.xxx 未訂閱
ADOTable2.TableName----這句話的意思是指資料表
你放的是資料庫檔案
當然會錯...

===================引 用 ann0509 文 章===================
ADOTable2.ConnectionString:= 'Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\S_Table\' S '.mdb';
ADOTable2.TableName := 'C:\S_Table\' S '.MDB\' S;

s 是我建立的資料庫名子跟資料庫資料表名子
我用輸入的方式 建立的
我寫第一行的時候不會有錯誤
到第二行的時候就會出現語法錯誤
ann0509
一般會員


發表:19
回覆:42
積分:12
註冊:2010-08-09

發送簡訊給我
#7 引用回覆 回覆 發表時間:2010-08-18 14:14:03 IP:60.248.xxx.xxx 訂閱
那應該怎麼打呢?
老大仔
尊榮會員


發表:77
回覆:835
積分:1082
註冊:2006-07-06

發送簡訊給我
#8 引用回覆 回覆 發表時間:2010-08-18 14:18:24 IP:59.120.xxx.xxx 未訂閱
當然是打上資料表名稱...
ann0509
一般會員


發表:19
回覆:42
積分:12
註冊:2010-08-09

發送簡訊給我
#9 引用回覆 回覆 發表時間:2010-08-18 14:58:19 IP:60.248.xxx.xxx 訂閱
感謝
我打上這樣
ADOTable2.TableName := S;
就可以了
謝謝阿 ^^
系統時間:2017-10-21 16:27:05
聯絡我們 | Delphi K.Top討論版
本站聲明
1. 本論壇為無營利行為之開放平台,所有文章都是由網友自行張貼,如牽涉到法律糾紛一切與本站無關。
2. 假如網友發表之內容涉及侵權,而損及您的利益,請立即通知版主刪除。
3. 請勿批評中華民國元首及政府或批評各政黨,是藍是綠本站無權干涉,但這裡不是政治性論壇!