全國最多中醫師線上諮詢網站-台灣中醫網
發文 回覆 瀏覽次數:1966
推到 Plurk!
推到 Facebook!

WebSnap 程式如何由Apache伺服器呼叫

缺席
cancer
高階會員


發表:58
回覆:319
積分:190
註冊:2004-07-31

發送簡訊給我
#1 引用回覆 回覆 發表時間:2005-05-16 00:02:49 IP:210.201.xxx.xxx 未訂閱
大大們, 有個問題想請教一下,我家的桌上型電腦裝了IIS伺服器,WebSnap產生的cgi程式可以在這台桌上型電腦執行。但是我又有一台宏碁的筆記型電腦,買回來就裝好了XP的家用版,因此不能安裝IIS,我又想把筆記型電腦帶到其他地方撰寫WebSnap程式,但沒有IIS 就不能執行所產生的Cgi或dll程式。如果我把整個硬碟重灌專業版的XP,則筆記型電腦出廠所安裝好的一些硬體偵測軟體就消失無蹤了。如果要繼續使用沒有IIS的XP,又想執行WebSnap產生的程式,該如何辨呢? 安裝Apache是不是解決方法之一? 我的桌上型電腦有裝了AppServ-1.9.0(Apache PHP MySql),預設目錄在 C:\AppServ\www 我把WebSnap產生的Cgi檔和所有PageProducer產生的 html 檔都放在www目錄裡面,在Browser裡面輸入 http://localhost/project2.cgi 結果,Browser報告說 Forbidden You don't have permission to access /project2.cgi on this server. 有甚麼辨法讓Apache執行我的Cgi檔呢? 謝謝在先
暗黑破壞神
版主


發表:9
回覆:2301
積分:1627
註冊:2004-10-04

發送簡訊給我
#2 引用回覆 回覆 發表時間:2005-05-16 00:34:31 IP:210.64.xxx.xxx 未訂閱
我的 httpd.conf 有以下幾行
ScriptAlias /cgi-bin/ "/usr/local/www/cgi-bin/"

    AllowOverride None
    Options None ExecCGI
    Order allow,deny
    Allow from all

我的 cgi 放在 /usr/local/www/cgi-bin 你自己調整你的目錄吧。
cancer
高階會員


發表:58
回覆:319
積分:190
註冊:2004-07-31

發送簡訊給我
#3 引用回覆 回覆 發表時間:2005-05-17 00:11:35 IP:210.201.xxx.xxx 未訂閱
破壞神大大, 謝謝您的解答,我有根據您的回應來試過,雖未成功,但有改善,因為看到你的回應時,已收到晚上十二點,沒時間再搞下去,明天再試試看,應該可以成功。
cancer
高階會員


發表:58
回覆:319
積分:190
註冊:2004-07-31

發送簡訊給我
#4 引用回覆 回覆 發表時間:2005-05-17 23:55:15 IP:210.201.xxx.xxx 未訂閱
破壞神大大,    一切OK,可以執行啦!原來把cgi檔放在cgi-bin目錄下,就能執行cgi檔,根本不必設定任何東西,這比IIS需要建立虛擬目錄並設定該目錄為可執行cgi,來 得簡單,因為安裝好Apache後,cgi-bin已預設為可執行cgi檔。 我查過我的httpd.conf檔,有一段是這樣的:     AllowOverride None Options None <-- 但是卻少了ExecCGI Order allow,deny Allow from all 我試過補上ExecCGI,發現不論是 Options None 或是 Options None ExecCGI cgi-bin中的cgi檔照樣能執行。 還是你的功勞讓我想到把cgi檔放在cgi-bin 目錄之下,謝謝您了。
系統時間:2017-12-16 15:27:06
聯絡我們 | Delphi K.Top討論版
本站聲明
1. 本論壇為無營利行為之開放平台,所有文章都是由網友自行張貼,如牽涉到法律糾紛一切與本站無關。
2. 假如網友發表之內容涉及侵權,而損及您的利益,請立即通知版主刪除。
3. 請勿批評中華民國元首及政府或批評各政黨,是藍是綠本站無權干涉,但這裡不是政治性論壇!