全國最多中醫師線上諮詢網站-台灣中醫網
發文 回覆 瀏覽次數:2063
推到 Plurk!
推到 Facebook!

請問Delphi4+BDE 升級符合window7 x64系統上執行

缺席
chyi55
一般會員


發表:2
回覆:2
積分:0
註冊:2012-12-24

發送簡訊給我
#1 引用回覆 回覆 發表時間:2014-02-06 12:50:43 IP:210.69.xxx.xxx 訂閱
想請教各位先進,是否有較好的建議或文章可以參考

1.Delphi4 BDE client/Server架構開發的程式如果要移轉到windows7 x64下執行,那一版本的delphi較為適合(程式碼改的最少),目前使用到的資料庫元件大致上是TDataBase與TQuery,其他較少使用,資料庫使用informix

2.BDE似乎不能在win7 x64下正常運作,討論區有講到ADOQuery與dbexpress,二者有什麼差別?

感恩~
編輯記錄
chyi55 重新編輯於 2014-02-06 13:09:12, 註解 無‧
herbert2
尊榮會員


發表:58
回覆:632
積分:878
註冊:2004-04-16

發送簡訊給我
#2 引用回覆 回覆 發表時間:2014-02-06 23:46:12 IP:202.39.xxx.xxx 訂閱
請參考:

http://delphi.ktop.com.tw/board.php?cid=168&fid=918&tid=104991

在 Windows 7 Pro 64 Bit 裝 Oracle XE 與 BDE 程式

隱約記得 BCB4 改至 BCB5 有很少的部分程式碼須做修改.
BDE V.5.2 可能無法與 Delphi 4 匹配, 若果真如此, 則須升級至 Delphi 5.
chyi55
一般會員


發表:2
回覆:2
積分:0
註冊:2012-12-24

發送簡訊給我
#3 引用回覆 回覆 發表時間:2014-02-07 23:15:20 IP:124.218.xxx.xxx 訂閱
感謝解答~
若是要改ado或dbexpress用那個版本的delphi較好?
===================引 用 herbert2 文 章===================
請參考:

http://delphi.ktop.com.tw/board.php?cid=168&fid=918&tid=104991

在 Windows 7 Pro 64 Bit 裝 Oracle XE 與 BDE 程式

隱約記得 BCB4 改至 BCB5 有很少的部分程式碼須做修改.
BDE V.5.2 可能無法與 Delphi 4 匹配, 若果真如此, 則須升級至 Delphi 5.
RootKit
資深會員


發表:16
回覆:357
積分:419
註冊:2008-01-02

發送簡訊給我
#4 引用回覆 回覆 發表時間:2014-02-12 20:51:01 IP:60.250.xxx.xxx 訂閱
 潛水太久冒個頭。

Delphi 4 -> Delphi 5 比較無痛。當然你也只能開發 32 位程式。
BDE -> ADO (Delphi 5 要更新到最後版) 。程式碼略改就好。

以上以修改幅度最小考量。

參考。
系統時間:2017-10-19 13:21:17
聯絡我們 | Delphi K.Top討論版
本站聲明
1. 本論壇為無營利行為之開放平台,所有文章都是由網友自行張貼,如牽涉到法律糾紛一切與本站無關。
2. 假如網友發表之內容涉及侵權,而損及您的利益,請立即通知版主刪除。
3. 請勿批評中華民國元首及政府或批評各政黨,是藍是綠本站無權干涉,但這裡不是政治性論壇!