全國最多中醫師線上諮詢網站-台灣中醫網
發文 回覆 瀏覽次數:1402
推到 Plurk!
推到 Facebook!

波形異常疑問

缺席
極光
初階會員


發表:32
回覆:96
積分:40
註冊:2005-01-16

發送簡訊給我
#1 引用回覆 回覆 發表時間:2011-10-11 22:57:09 IP:59.105.xxx.xxx 訂閱
小弟最近遇到一個奇怪的問題,遇到如同我上傳附檔的波形圖那樣。會發生一支突波訊號,因與ECU通訊是採用UART方式傳輸,而UART是使用MCU硬體內建功能完成,但應突波訊號而使UART硬體取樣時會發生取樣錯誤,而使整筆資料因檢查碼不過而做刪除不用。

但讓小弟感到疑惑的,此回應訊號是對方ECU回應的。而資料傳遞是採用KLine型態來傳輸,因此是使用OC的方式來傳遞。所以訊號"1"表示提升電阻拉上去的,而訊號"0"則是透過電晶體拉地而產生。

所以通訊中的"1"是透過提升電組給予的,但訊號"0"則是對方的電晶體向下拉地,但可疑的是位什麼會用圖中的突波產生,我找了好久都不知道是那邊跑過去的。

請教前輩,是說可能我的DC-DC降壓POWER的雜訊跑過去,但為什麼會發生再ECU回應拉地時產生如此高的突波呢?

我再電源輸入端接了共厄線圈與再KLine 12V電源端接LC濾波器都無法抑制此雜訊產生?


附加檔案:4e94594539dde_B.JPG
編輯記錄
極光 重新編輯於 2011-10-11 08:57:41, 註解 無‧
極光 重新編輯於 2011-10-11 09:10:36, 註解 無‧
極光 重新編輯於 2011-10-11 09:11:16, 註解 無‧
極光 重新編輯於 2011-10-11 09:11:58, 註解 無‧
ScottWang
版主


發表:32
回覆:486
積分:688
註冊:2009-04-27

發送簡訊給我
#2 引用回覆 回覆 發表時間:2011-10-12 01:59:34 IP:59.115.xxx.xxx 訂閱
 1. 你可以在傳送與接收信號之間,串接一個610Ω電阻和103(0.01uf)接地,做為RC積分濾波(依據突波為162.55KHz),電阻值可以根據信號做調整.
在做為濾波的同時,正常波形10Khz也會被改變一些,只要接收端能夠正確辨識就沒有問題,重點在於濾除突波時,其阻值對於正常波形影響的拿捏,10Khz與162.55Khz,兩者相差約有16倍,我以約160Khz和16khz做了初步測試,應該是可行的.
2. 對於真正發生問題的原因,能夠找出來最好,你可以畫個傳送與接收信號整體電路的方塊圖,含電源和信號走向,這樣或許對於分析有些助益.

如果對於頻率的理解有錯誤的話,煩請告知.
------
高壓模組,高壓直流電源供應器(全範圍可調電壓電流),中低壓直流電源供應器,電壓放大器,
電流放大器,帶通濾波器,高精度參考電壓,標準電壓,恆流源(定電流源),恆壓源(定電壓源),
測試LED專用AC LED定電流源,專門接受訂製,設計生產各種特殊規格,高精度產品,學校實驗室,
研究單位實驗設備,另可接受其它電子專案設計,HV Power,Vmax=20KV,Imax=2000A.
http://hvpower.myweb.hinet.net/
...Scott Wang...
編輯記錄
ScottWang 重新編輯於 2011-10-11 12:05:35, 註解 無‧
極光
初階會員


發表:32
回覆:96
積分:40
註冊:2005-01-16

發送簡訊給我
#3 引用回覆 回覆 發表時間:2011-10-12 22:48:57 IP:59.105.xxx.xxx 訂閱

===================引 用 ScottWang 文 章===================
1. 你可以在傳送與接收信號之間,串接一個610Ω電阻和103(0.01uf)接地,做為RC積分濾波(依據突波為162.55KHz),電阻值可以根據信號做調整.
在做為濾波的同時,正常波形10Khz也會被改變一些,只要接收端能夠正確辨識就沒有問題,重點在於濾除突波時,其阻值對於正常波形影響的拿捏,10Khz與162.55Khz,兩者相差約有16倍,我以約160Khz和16khz做了初步測試,應該是可行的.
2. 對於真正發生問題的原因,能夠找出來最好,你可以畫個傳送與接收信號整體電路的方塊圖,含電源和信號走向,這樣或許對於分析有些助益.

如果對於頻率的理解有錯誤的話,煩請告知.

我有實驗過接電容可以成功濾除該突波,但只能將此辦法擺到最後,因覺的必須把原因找出,否則不算電路還是有問題。這幾天都在忙著尋找原因,但把可能導致的零件依依拆解,都還是沒有發現為何產生?

而且該功能在上一代產品是可以正常運作的,這代產品多加了幾項功能就發生此事件發生?讓人摸不著頭蓄。

本以為是dc-dc引起的,將電源改回上一代產品使用的線性穩壓電路,但還是產生該突波。現在推論因該是加入什麼元件而使該突波產生,所以只能使用刪除法,來逆推答案。
kib72377
高階會員


發表:1
回覆:217
積分:238
註冊:2004-11-12

發送簡訊給我
#4 引用回覆 回覆 發表時間:2011-10-13 10:08:57 IP:125.233.xxx.xxx 未訂閱

猜想,資料傳送的 開始或結束有一個瞬間的on/off信號,
可能是硬體reset所產生瞬間狀態值不穩定.
編輯記錄
kib72377 重新編輯於 2011-10-12 20:09:42, 註解 無‧
極光
初階會員


發表:32
回覆:96
積分:40
註冊:2005-01-16

發送簡訊給我
#5 引用回覆 回覆 發表時間:2011-10-16 23:24:31 IP:59.105.xxx.xxx 訂閱


這是我電源線路的圖塊,後來稿到最後都沒有什麼想法,只好請老師傅出馬。老師傅現場看了也覺的找不出為什麼會有下面的雜訊。



而且須在機車發動時才會看到,後來就在電源最外部的二級體並連0.1uF的陶池電容就可以成功抑止此突波的高度,透過示波器可以看到,本來會到達約11V高度的突波,會衰減到1V左右,因此就不會可將忽略不記。

產生原因還是不清楚,因為只有特定機車才會發生,其他的車子就沒有,所以也很納悶!但可以確定因該是由機車本身雜訊產生,但不知什麼原因透過板子而產生此突波發生。

果然車子上的世界果然很奧妙阿!在此也發現自己的硬體底子果然太差了。

kib72377
高階會員


發表:1
回覆:217
積分:238
註冊:2004-11-12

發送簡訊給我
#6 引用回覆 回覆 發表時間:2011-10-17 09:08:41 IP:125.233.xxx.xxx 未訂閱
最前級再加個 L C 濾波試看看.
系統時間:2017-10-24 15:53:39
聯絡我們 | Delphi K.Top討論版
本站聲明
1. 本論壇為無營利行為之開放平台,所有文章都是由網友自行張貼,如牽涉到法律糾紛一切與本站無關。
2. 假如網友發表之內容涉及侵權,而損及您的利益,請立即通知版主刪除。
3. 請勿批評中華民國元首及政府或批評各政黨,是藍是綠本站無權干涉,但這裡不是政治性論壇!